re = /^https?:\/\/[^\n]+$/i
str = 'javascript:exploit_code();/*
http://hi.com
*/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end