$re = '/[^&\w]|_/m';
$str = 'ss123.2=9&&23=s\\\\/s\'".,;;:][}{+-—__=*&&^^%$#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);