$re = '/(?:[^\x00-\x7F])/';
$str = 'Yes$
No€
Nođź „
Furhter像';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);