#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:31(\/|-|\.)(?:0?[13578]|1[02]))\1|(?:(?:29|30)(\/|-|\.)(?:0?[1,3-9]|1[0-2])\2))(?:(?:1[6-9]|[2-9]\d)?\d{2})$|^(?:29(\/|-|\.)0?2\3(?:(?:(?:1[6-9]|[2-9]\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))$|^(?:0?[1-9]|1\d|2[0-8])(\/|-|\.)(?:(?:0?[1-9])|(?:1[0-2]))\4(?:(?:1[6-9]|[2-9]\d)?\d{2})$"
Local $sString = "11.01.2010" & @CRLF & _
"11.12.12" & @CRLF & _
"01-12-12" & @CRLF & _
"01/12/2012" & @CRLF & _
"11/12/12" & @CRLF & _
"01.12.2010" & @CRLF & _
"01.04.1993" & @CRLF & _
"03.06.93" & @CRLF & _
"01 08 1991" & @CRLF & _
"29.02.200" & @CRLF & _
"9562 6232 5695 2659" & @CRLF & _
"864797" & @CRLF & _
"3354713559" & @CRLF & _
"+380 44 555 12 34" & @CRLF & _
"555 12 34" & @CRLF & _
"0 44 555 12 34"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")