$re = '/Shipped on\s\w+\.\s\d{2},\s\d{4}/m';
$str = 'Shipped on Aug. 29, 2017';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);