#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<country>.*?)\s(?<a2>\w\w)\s(?<a3>\w\w\w)\s\d+\sISO\s3166-2:(?<iso>\w\w)\t(Yes|No)"
Local $sString = "Afghanistan AF AFG 004 ISO 3166-2:AF Yes" & @CRLF & _
"Åland Islands AX ALA 248 ISO 3166-2:AX No" & @CRLF & _
"Albania AL ALB 008 ISO 3166-2:AL Yes" & @CRLF & _
"Algeria DZ DZA 012 ISO 3166-2:DZ Yes" & @CRLF & _
"American Samoa AS ASM 016 ISO 3166-2:AS No" & @CRLF & _
"Andorra AD AND 020 ISO 3166-2:AD Yes" & @CRLF & _
"Angola AO AGO 024 ISO 3166-2:AO Yes" & @CRLF & _
"Anguilla AI AIA 660 ISO 3166-2:AI No" & @CRLF & _
"Antarctica AQ ATA 010 ISO 3166-2:AQ No" & @CRLF & _
"Antigua and Barbuda AG ATG 028 ISO 3166-2:AG Yes" & @CRLF & _
"Argentina AR ARG 032 ISO 3166-2:AR Yes" & @CRLF & _
"Armenia AM ARM 051 ISO 3166-2:AM Yes" & @CRLF & _
"Aruba AW ABW 533 ISO 3166-2:AW No" & @CRLF & _
"Australia AU AUS 036 ISO 3166-2:AU Yes" & @CRLF & _
"Austria AT AUT 040 ISO 3166-2:AT Yes" & @CRLF & _
"Azerbaijan AZ AZE 031 ISO 3166-2:AZ Yes" & @CRLF & _
"Bahamas BS BHS 044 ISO 3166-2:BS Yes" & @CRLF & _
"Bahrain BH BHR 048 ISO 3166-2:BH Yes" & @CRLF & _
"Bangladesh BD BGD 050 ISO 3166-2:BD Yes" & @CRLF & _
"Barbados BB BRB 052 ISO 3166-2:BB Yes" & @CRLF & _
"Belarus BY BLR 112 ISO 3166-2:BY Yes" & @CRLF & _
"Belgium BE BEL 056 ISO 3166-2:BE Yes" & @CRLF & _
"Belize BZ BLZ 084 ISO 3166-2:BZ Yes" & @CRLF & _
"Benin BJ BEN 204 ISO 3166-2:BJ Yes" & @CRLF & _
"Bermuda BM BMU 060 ISO 3166-2:BM No" & @CRLF & _
"Bhutan BT BTN 064 ISO 3166-2:BT Yes" & @CRLF & _
"Bolivia (Plurinational State of) BO BOL 068 ISO 3166-2:BO Yes" & @CRLF & _
"Bonaire, Sint Eustatius and Saba BQ BES 535 ISO 3166-2:BQ No" & @CRLF & _
"Bosnia and Herzegovina BA BIH 070 ISO 3166-2:BA Yes" & @CRLF & _
"Botswana BW BWA 072 ISO 3166-2:BW Yes" & @CRLF & _
"Bouvet Island BV BVT 074 ISO 3166-2:BV No" & @CRLF & _
"Brazil BR BRA 076 ISO 3166-2:BR Yes" & @CRLF & _
"British Indian Ocean Territory IO IOT 086 ISO 3166-2:IO No" & @CRLF & _
"Brunei Darussalam BN BRN 096 ISO 3166-2:BN Yes" & @CRLF & _
"Bulgaria BG BGR 100 ISO 3166-2:BG Yes" & @CRLF & _
"Burkina Faso BF BFA 854 ISO 3166-2:BF Yes" & @CRLF & _
"Burundi BI BDI 108 ISO 3166-2:BI Yes" & @CRLF & _
"Cabo Verde CV CPV 132 ISO 3166-2:CV Yes" & @CRLF & _
"Cambodia KH KHM 116 ISO 3166-2:KH Yes" & @CRLF & _
"Cameroon CM CMR 120 ISO 3166-2:CM Yes" & @CRLF & _
"Canada CA CAN 124 ISO 3166-2:CA Yes" & @CRLF & _
"Cayman Islands KY CYM 136 ISO 3166-2:KY No" & @CRLF & _
"Central African Republic CF CAF 140 ISO 3166-2:CF Yes" & @CRLF & _
"Chad TD TCD 148 ISO 3166-2:TD Yes" & @CRLF & _
"Chile CL CHL 152 ISO 3166-2:CL Yes" & @CRLF & _
"China CN CHN 156 ISO 3166-2:CN Yes" & @CRLF & _
"Christmas Island CX CXR 162 ISO 3166-2:CX No" & @CRLF & _
"Cocos (Keeling) Islands CC CCK 166 ISO 3166-2:CC No" & @CRLF & _
"Colombia CO COL 170 ISO 3166-2:CO Yes" & @CRLF & _
"Comoros KM COM 174 ISO 3166-2:KM Yes" & @CRLF & _
"Congo CG COG 178 ISO 3166-2:CG Yes" & @CRLF & _
"Congo (Democratic Republic of the) CD COD 180 ISO 3166-2:CD Yes" & @CRLF & _
"Cook Islands CK COK 184 ISO 3166-2:CK No" & @CRLF & _
"Costa Rica CR CRI 188 ISO 3166-2:CR Yes" & @CRLF & _
"Côte d'Ivoire CI CIV 384 ISO 3166-2:CI Yes" & @CRLF & _
"Croatia HR HRV 191 ISO 3166-2:HR Yes" & @CRLF & _
"Cuba CU CUB 192 ISO 3166-2:CU Yes" & @CRLF & _
"Curaçao CW CUW 531 ISO 3166-2:CW No" & @CRLF & _
"Cyprus CY CYP 196 ISO 3166-2:CY Yes" & @CRLF & _
"Czechia CZ CZE 203 ISO 3166-2:CZ Yes" & @CRLF & _
"Denmark DK DNK 208 ISO 3166-2:DK Yes" & @CRLF & _
"Djibouti DJ DJI 262 ISO 3166-2:DJ Yes" & @CRLF & _
"Dominica DM DMA 212 ISO 3166-2:DM Yes" & @CRLF & _
"Dominican Republic DO DOM 214 ISO 3166-2:DO Yes" & @CRLF & _
"Ecuador EC ECU 218 ISO 3166-2:EC Yes" & @CRLF & _
"Egypt EG EGY 818 ISO 3166-2:EG Yes" & @CRLF & _
"El Salvador SV SLV 222 ISO 3166-2:SV Yes" & @CRLF & _
"Equatorial Guinea GQ GNQ 226 ISO 3166-2:GQ Yes" & @CRLF & _
"Eritrea ER ERI 232 ISO 3166-2:ER Yes" & @CRLF & _
"Estonia EE EST 233 ISO 3166-2:EE Yes" & @CRLF & _
"Ethiopia ET ETH 231 ISO 3166-2:ET Yes" & @CRLF & _
"Falkland Islands (Malvinas) FK FLK 238 ISO 3166-2:FK No" & @CRLF & _
"Faroe Islands FO FRO 234 ISO 3166-2:FO No" & @CRLF & _
"Fiji FJ FJI 242 ISO 3166-2:FJ Yes" & @CRLF & _
"Finland FI FIN 246 ISO 3166-2:FI Yes" & @CRLF & _
"France FR FRA 250 ISO 3166-2:FR Yes" & @CRLF & _
"French Guiana GF GUF 254 ISO 3166-2:GF No" & @CRLF & _
"French Polynesia PF PYF 258 ISO 3166-2:PF No" & @CRLF & _
"French Southern Territories TF ATF 260 ISO 3166-2:TF No" & @CRLF & _
"Gabon GA GAB 266 ISO 3166-2:GA Yes" & @CRLF & _
"Gambia GM GMB 270 ISO 3166-2:GM Yes" & @CRLF & _
"Georgia GE GEO 268 ISO 3166-2:GE Yes" & @CRLF & _
"Germany DE DEU 276 ISO 3166-2:DE Yes" & @CRLF & _
"Ghana GH GHA 288 ISO 3166-2:GH Yes" & @CRLF & _
"Gibraltar GI GIB 292 ISO 3166-2:GI No" & @CRLF & _
"Greece GR GRC 300 ISO 3166-2:GR Yes" & @CRLF & _
"Greenland GL GRL 304 ISO 3166-2:GL No" & @CRLF & _
"Grenada GD GRD 308 ISO 3166-2:GD Yes" & @CRLF & _
"Guadeloupe GP GLP 312 ISO 3166-2:GP No" & @CRLF & _
"Guam GU GUM 316 ISO 3166-2:GU No" & @CRLF & _
"Guatemala GT GTM 320 ISO 3166-2:GT Yes" & @CRLF & _
"Guernsey GG GGY 831 ISO 3166-2:GG No" & @CRLF & _
"Guinea GN GIN 324 ISO 3166-2:GN Yes" & @CRLF & _
"Guinea-Bissau GW GNB 624 ISO 3166-2:GW Yes" & @CRLF & _
"Guyana GY GUY 328 ISO 3166-2:GY Yes" & @CRLF & _
"Haiti HT HTI 332 ISO 3166-2:HT Yes" & @CRLF & _
"Heard Island and McDonald Islands HM HMD 334 ISO 3166-2:HM No" & @CRLF & _
"Holy See VA VAT 336 ISO 3166-2:VA Yes" & @CRLF & _
"Honduras HN HND 340 ISO 3166-2:HN Yes" & @CRLF & _
"Hong Kong HK HKG 344 ISO 3166-2:HK No" & @CRLF & _
"Hungary HU HUN 348 ISO 3166-2:HU Yes" & @CRLF & _
"Iceland IS ISL 352 ISO 3166-2:IS Yes" & @CRLF & _
"India IN IND 356 ISO 3166-2:IN Yes" & @CRLF & _
"Indonesia ID IDN 360 ISO 3166-2:ID Yes" & @CRLF & _
"Iran (Islamic Republic of) IR IRN 364 ISO 3166-2:IR Yes" & @CRLF & _
"Iraq IQ IRQ 368 ISO 3166-2:IQ Yes" & @CRLF & _
"Ireland IE IRL 372 ISO 3166-2:IE Yes" & @CRLF & _
"Isle of Man IM IMN 833 ISO 3166-2:IM No" & @CRLF & _
"Israel IL ISR 376 ISO 3166-2:IL Yes" & @CRLF & _
"Italy IT ITA 380 ISO 3166-2:IT Yes" & @CRLF & _
"Jamaica JM JAM 388 ISO 3166-2:JM Yes" & @CRLF & _
"Japan JP JPN 392 ISO 3166-2:JP Yes" & @CRLF & _
"Jersey JE JEY 832 ISO 3166-2:JE No" & @CRLF & _
"Jordan JO JOR 400 ISO 3166-2:JO Yes" & @CRLF & _
"Kazakhstan KZ KAZ 398 ISO 3166-2:KZ Yes" & @CRLF & _
"Kenya KE KEN 404 ISO 3166-2:KE Yes" & @CRLF & _
"Kiribati KI KIR 296 ISO 3166-2:KI Yes" & @CRLF & _
"Korea (Democratic People's Republic of) KP PRK 408 ISO 3166-2:KP Yes" & @CRLF & _
"Korea (Republic of) KR KOR 410 ISO 3166-2:KR Yes" & @CRLF & _
"Kuwait KW KWT 414 ISO 3166-2:KW Yes" & @CRLF & _
"Kyrgyzstan KG KGZ 417 ISO 3166-2:KG Yes" & @CRLF & _
"Lao People's Democratic Republic LA LAO 418 ISO 3166-2:LA Yes" & @CRLF & _
"Latvia LV LVA 428 ISO 3166-2:LV Yes" & @CRLF & _
"Lebanon LB LBN 422 ISO 3166-2:LB Yes" & @CRLF & _
"Lesotho LS LSO 426 ISO 3166-2:LS Yes" & @CRLF & _
"Liberia LR LBR 430 ISO 3166-2:LR Yes" & @CRLF & _
"Libya LY LBY 434 ISO 3166-2:LY Yes" & @CRLF & _
"Liechtenstein LI LIE 438 ISO 3166-2:LI Yes" & @CRLF & _
"Lithuania LT LTU 440 ISO 3166-2:LT Yes" & @CRLF & _
"Luxembourg LU LUX 442 ISO 3166-2:LU Yes" & @CRLF & _
"Macao MO MAC 446 ISO 3166-2:MO No" & @CRLF & _
"Macedonia (the former Yugoslav Republic of) MK MKD 807 ISO 3166-2:MK Yes" & @CRLF & _
"Madagascar MG MDG 450 ISO 3166-2:MG Yes" & @CRLF & _
"Malawi MW MWI 454 ISO 3166-2:MW Yes" & @CRLF & _
"Malaysia MY MYS 458 ISO 3166-2:MY Yes" & @CRLF & _
"Maldives MV MDV 462 ISO 3166-2:MV Yes" & @CRLF & _
"Mali ML MLI 466 ISO 3166-2:ML Yes" & @CRLF & _
"Malta MT MLT 470 ISO 3166-2:MT Yes" & @CRLF & _
"Marshall Islands MH MHL 584 ISO 3166-2:MH Yes" & @CRLF & _
"Martinique MQ MTQ 474 ISO 3166-2:MQ No" & @CRLF & _
"Mauritania MR MRT 478 ISO 3166-2:MR Yes" & @CRLF & _
"Mauritius MU MUS 480 ISO 3166-2:MU Yes" & @CRLF & _
"Mayotte YT MYT 175 ISO 3166-2:YT No" & @CRLF & _
"Mexico MX MEX 484 ISO 3166-2:MX Yes" & @CRLF & _
"Micronesia (Federated States of) FM FSM 583 ISO 3166-2:FM Yes" & @CRLF & _
"Moldova (Republic of) MD MDA 498 ISO 3166-2:MD Yes" & @CRLF & _
"Monaco MC MCO 492 ISO 3166-2:MC Yes" & @CRLF & _
"Mongolia MN MNG 496 ISO 3166-2:MN Yes" & @CRLF & _
"Montenegro ME MNE 499 ISO 3166-2:ME Yes" & @CRLF & _
"Montserrat MS MSR 500 ISO 3166-2:MS No" & @CRLF & _
"Morocco MA MAR 504 ISO 3166-2:MA Yes" & @CRLF & _
"Mozambique MZ MOZ 508 ISO 3166-2:MZ Yes" & @CRLF & _
"Myanmar MM MMR 104 ISO 3166-2:MM Yes" & @CRLF & _
"Namibia NA NAM 516 ISO 3166-2:NA Yes" & @CRLF & _
"Nauru NR NRU 520 ISO 3166-2:NR Yes" & @CRLF & _
"Nepal NP NPL 524 ISO 3166-2:NP Yes" & @CRLF & _
"Netherlands NL NLD 528 ISO 3166-2:NL Yes" & @CRLF & _
"New Caledonia NC NCL 540 ISO 3166-2:NC No" & @CRLF & _
"New Zealand NZ NZL 554 ISO 3166-2:NZ Yes" & @CRLF & _
"Nicaragua NI NIC 558 ISO 3166-2:NI Yes" & @CRLF & _
"Niger NE NER 562 ISO 3166-2:NE Yes" & @CRLF & _
"Nigeria NG NGA 566 ISO 3166-2:NG Yes" & @CRLF & _
"Niue NU NIU 570 ISO 3166-2:NU No" & @CRLF & _
"Norfolk Island NF NFK 574 ISO 3166-2:NF No" & @CRLF & _
"Northern Mariana Islands MP MNP 580 ISO 3166-2:MP No" & @CRLF & _
"Norway NO NOR 578 ISO 3166-2:NO Yes" & @CRLF & _
"Oman OM OMN 512 ISO 3166-2:OM Yes" & @CRLF & _
"Pakistan PK PAK 586 ISO 3166-2:PK Yes" & @CRLF & _
"Palau PW PLW 585 ISO 3166-2:PW Yes" & @CRLF & _
"Palestine, State of PS PSE 275 ISO 3166-2:PS No" & @CRLF & _
"Panama PA PAN 591 ISO 3166-2:PA Yes" & @CRLF & _
"Papua New Guinea PG PNG 598 ISO 3166-2:PG Yes" & @CRLF & _
"Paraguay PY PRY 600 ISO 3166-2:PY Yes" & @CRLF & _
"Peru PE PER 604 ISO 3166-2:PE Yes" & @CRLF & _
"Philippines PH PHL 608 ISO 3166-2:PH Yes" & @CRLF & _
"Pitcairn PN PCN 612 ISO 3166-2:PN No" & @CRLF & _
"Poland PL POL 616 ISO 3166-2:PL Yes" & @CRLF & _
"Portugal PT PRT 620 ISO 3166-2:PT Yes" & @CRLF & _
"Puerto Rico PR PRI 630 ISO 3166-2:PR No" & @CRLF & _
"Qatar QA QAT 634 ISO 3166-2:QA Yes" & @CRLF & _
"Réunion RE REU 638 ISO 3166-2:RE No" & @CRLF & _
"Romania RO ROU 642 ISO 3166-2:RO Yes" & @CRLF & _
"Russian Federation RU RUS 643 ISO 3166-2:RU Yes" & @CRLF & _
"Rwanda RW RWA 646 ISO 3166-2:RW Yes" & @CRLF & _
"Saint Barthélemy BL BLM 652 ISO 3166-2:BL No" & @CRLF & _
"Saint Helena, Ascension and Tristan da Cunha SH SHN 654 ISO 3166-2:SH No" & @CRLF & _
"Saint Kitts and Nevis KN KNA 659 ISO 3166-2:KN Yes" & @CRLF & _
"Saint Lucia LC LCA 662 ISO 3166-2:LC Yes" & @CRLF & _
"Saint Martin (French part) MF MAF 663 ISO 3166-2:MF No" & @CRLF & _
"Saint Pierre and Miquelon PM SPM 666 ISO 3166-2:PM No" & @CRLF & _
"Saint Vincent and the Grenadines VC VCT 670 ISO 3166-2:VC Yes" & @CRLF & _
"Samoa WS WSM 882 ISO 3166-2:WS Yes" & @CRLF & _
"San Marino SM SMR 674 ISO 3166-2:SM Yes" & @CRLF & _
"Sao Tome and Principe ST STP 678 ISO 3166-2:ST Yes" & @CRLF & _
"Saudi Arabia SA SAU 682 ISO 3166-2:SA Yes" & @CRLF & _
"Senegal SN SEN 686 ISO 3166-2:SN Yes" & @CRLF & _
"Serbia RS SRB 688 ISO 3166-2:RS Yes" & @CRLF & _
"Seychelles SC SYC 690 ISO 3166-2:SC Yes" & @CRLF & _
"Sierra Leone SL SLE 694 ISO 3166-2:SL Yes" & @CRLF & _
"Singapore SG SGP 702 ISO 3166-2:SG Yes" & @CRLF & _
"Sint Maarten (Dutch part) SX SXM 534 ISO 3166-2:SX No" & @CRLF & _
"Slovakia SK SVK 703 ISO 3166-2:SK Yes" & @CRLF & _
"Slovenia SI SVN 705 ISO 3166-2:SI Yes" & @CRLF & _
"Solomon Islands SB SLB 090 ISO 3166-2:SB Yes" & @CRLF & _
"Somalia SO SOM 706 ISO 3166-2:SO Yes" & @CRLF & _
"South Africa ZA ZAF 710 ISO 3166-2:ZA Yes" & @CRLF & _
"South Georgia and the South Sandwich Islands GS SGS 239 ISO 3166-2:GS No" & @CRLF & _
"South Sudan SS SSD 728 ISO 3166-2:SS Yes" & @CRLF & _
"Spain ES ESP 724 ISO 3166-2:ES Yes" & @CRLF & _
"Sri Lanka LK LKA 144 ISO 3166-2:LK Yes" & @CRLF & _
"Sudan SD SDN 729 ISO 3166-2:SD Yes" & @CRLF & _
"Suriname SR SUR 740 ISO 3166-2:SR Yes" & @CRLF & _
"Svalbard and Jan Mayen SJ SJM 744 ISO 3166-2:SJ No" & @CRLF & _
"Swaziland SZ SWZ 748 ISO 3166-2:SZ Yes" & @CRLF & _
"Sweden SE SWE 752 ISO 3166-2:SE Yes" & @CRLF & _
"Switzerland CH CHE 756 ISO 3166-2:CH Yes" & @CRLF & _
"Syrian Arab Republic SY SYR 760 ISO 3166-2:SY Yes" & @CRLF & _
"Taiwan, Province of China[a] TW TWN 158 ISO 3166-2:TW No" & @CRLF & _
"Tajikistan TJ TJK 762 ISO 3166-2:TJ Yes" & @CRLF & _
"Tanzania, United Republic of TZ TZA 834 ISO 3166-2:TZ Yes" & @CRLF & _
"Thailand TH THA 764 ISO 3166-2:TH Yes" & @CRLF & _
"Timor-Leste TL TLS 626 ISO 3166-2:TL Yes" & @CRLF & _
"Togo TG TGO 768 ISO 3166-2:TG Yes" & @CRLF & _
"Tokelau TK TKL 772 ISO 3166-2:TK No" & @CRLF & _
"Tonga TO TON 776 ISO 3166-2:TO Yes" & @CRLF & _
"Trinidad and Tobago TT TTO 780 ISO 3166-2:TT Yes" & @CRLF & _
"Tunisia TN TUN 788 ISO 3166-2:TN Yes" & @CRLF & _
"Turkey TR TUR 792 ISO 3166-2:TR Yes" & @CRLF & _
"Turkmenistan TM TKM 795 ISO 3166-2:TM Yes" & @CRLF & _
"Turks and Caicos Islands TC TCA 796 ISO 3166-2:TC No" & @CRLF & _
"Tuvalu TV TUV 798 ISO 3166-2:TV Yes" & @CRLF & _
"Uganda UG UGA 800 ISO 3166-2:UG Yes" & @CRLF & _
"Ukraine UA UKR 804 ISO 3166-2:UA Yes" & @CRLF & _
"United Arab Emirates AE ARE 784 ISO 3166-2:AE Yes" & @CRLF & _
"United Kingdom of Great Britain and Northern Ireland GB GBR 826 ISO 3166-2:GB Yes" & @CRLF & _
"United States of America US USA 840 ISO 3166-2:US Yes" & @CRLF & _
"United States Minor Outlying Islands UM UMI 581 ISO 3166-2:UM No" & @CRLF & _
"Uruguay UY URY 858 ISO 3166-2:UY Yes" & @CRLF & _
"Uzbekistan UZ UZB 860 ISO 3166-2:UZ Yes" & @CRLF & _
"Vanuatu VU VUT 548 ISO 3166-2:VU Yes" & @CRLF & _
"Venezuela (Bolivarian Republic of) VE VEN 862 ISO 3166-2:VE Yes" & @CRLF & _
"Viet Nam VN VNM 704 ISO 3166-2:VN Yes" & @CRLF & _
"Virgin Islands (British) VG VGB 092 ISO 3166-2:VG No" & @CRLF & _
"Virgin Islands (U.S.) VI VIR 850 ISO 3166-2:VI No" & @CRLF & _
"Wallis and Futuna WF WLF 876 ISO 3166-2:WF No" & @CRLF & _
"Western Sahara EH ESH 732 ISO 3166-2:EH No" & @CRLF & _
"Yemen YE YEM 887 ISO 3166-2:YE Yes" & @CRLF & _
"Zambia ZM ZMB 894 ISO 3166-2:ZM Yes" & @CRLF & _
"Zimbabwe ZW ZWE 716 ISO 3166-2:ZW Yes"
Local $sSubst = "${country},${a2},${a3},${iso}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)