$re = '/\d(?=(?:(?:\d{3})+),)/';
$str = '54383197769,438567894376';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);