using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^SageAccts Company Name 2018-[01][0-9]-([0-3][0-9]) [0-2][0-9]-[0-5][0-9]-[0-5][0-9]$";
string input = @"SageAccts Company Name 2018-06-01 00-00-10
SageAccts Company Name 2018-06-02 00-00-10
SageAccts Company Name 2018-06-03 00-00-10
SageAccts Company Name 2018-06-04 00-00-10
SageAccts Company Name 2018-06-05 00-00-10
SageAccts Company Name 2018-06-06 00-00-10
SageAccts Company Name 2018-06-07 00-00-10
SageAccts Company Name 2018-06-08 00-00-10
SageAccts Company Name 2018-06-09 00-00-10
SageAccts Company Name 2018-06-10 00-00-10
SageAccts Company Name 2018-06-11 00-00-10
SageAccts Company Name 2018-06-12 00-00-10
SageAccts Company Name 2018-06-13 00-00-10
SageAccts Company Name 2018-06-14 00-00-10
SageAccts Company Name 2018-06-15 00-00-10
SageAccts Company Name 2018-06-16 00-00-10
SageAccts Company Name 2018-06-17 00-00-10
SageAccts Company Name 2018-06-18 00-00-10
SageAccts Company Name 2018-06-19 00-00-10
SageAccts Company Name 2018-06-20 00-00-10
SageAccts Company Name 2018-06-21 00-00-10
SageAccts Company Name 2018-06-22 00-00-10
SageAccts Company Name 2018-06-23 00-00-10
SageAccts Company Name 2018-06-24 00-00-10
SageAccts Company Name 2018-06-25 00-00-10
SageAccts Company Name 2018-06-26 00-00-10
SageAccts Company Name 2018-06-27 00-00-10
SageAccts Company Name 2018-06-28 00-00-10
SageAccts Company Name 2018-06-29 00-00-10
SageAccts Company Name 2018-06-30 00-00-10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}