import re
regex = re.compile(r"^((0)*[1-9]|1[012]|3[01])-((0)*[1-9]|1[012]|2[012]|3[01])-(19[0-9][0-9]|20[0-9][0-9])$", flags=re.MULTILINE)
test_str = ("02-19-2020\n"
"12-3-2020\n"
"3-12-2020\n"
"3-4-1222\n"
"31-07-2321\n"
"7-7-2083")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")