# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<float>^\d+\.\d+\s)(?P<beforeTEST>(?:(?!(?P>float)).)*)\bTEST\b(?P>beforeTEST)"
test_str = ("asdasdasda\n"
"2.1 adasdasdasdasdwvwetwevtwtv\n"
"wetvwetv TEST wqrqwvrqw\n"
"qwvrqwvqwr\n"
"2.2 whergtvwe\n"
"wetvwetvwetveatw\n"
"evtwet\n"
"2.3 eyrnenytunrunert\n"
"vqevrerwv TEST aevtawtvwetv\n"
"wetvwetv TEST wqrqwvrqw\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.