using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=http).+";
string input = @"The following store has been approved Location No : 21872 India : Mumbai AIf @ MAST Market No : 464738 https://pdportal.8-ten.com/Main/ProjectMain.aspx?projectLocationId=427409";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}