re = /(?=http)\S+/m
str = 'The following store has been approved Location No : 21872 India : Mumbai AIf @ MAST Market No : 464738 https://pdportal.8-ten.com/Main/ProjectMain.aspx?projectLocationId=427409 aa zxxcc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end