#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z]+)\s+([-\d\s]+)"
Local $sString = "Simon" & @CRLF & _
"" & @CRLF & _
"5 0 0 0 0 0 0 1 0 1 -3 5 0 0 0 5 5 0 0 0 0 5 0 0 0 0 0 0 0 0 1 3 0 1 0 -5 0 " & @CRLF & _
"0 5 5 0 5 5 5 0 5 5 0 0 0 5 5 5 5 -5 " & @CRLF & _
"" & @CRLF & _
"John" & @CRLF & _
"" & @CRLF & _
"5 5 0 0 0 0 3 0 0 1 0 5 3 0 5 0 3 3 5 0 0 0 0 0 5 0 0 0 0 0 3 5 0 0 0 0 0 5 " & @CRLF & _
"-3 0 0 0 5 0 0 0 0 0 0 5 5 0 3 0 0 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")