package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bPay\s*\$(\d+(?:\.\d+)?)`)
var str = `Pay $3.14`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}