$re = '/(^[0-9]{6}\.[0-9]{2}$|^$)/m';
$str = '999999.99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);