re = /https:\/\/(?<word>\w+)/m
str = 'nodeUrl=https://sappbos.aexp.com/odata.svc/v1.0/BlazeoData/UddsSappSupplierPymntAccpts?
nodeUrl=https://merchantcompass.aexp.com/odata.svc/v1.0/BlazeoData/MerchantCompassLookups'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end