$re = '/.{4}(\w+ \d+ \d+:\d+:\d+) ([\w\d-]+) (?:\[([\w\d-]+)\]|)\[([\w\d]+)\]\[(\w+)\]\[(\w+)\] (?:([\w\s-]+)\(([\w\s-]+)\): |)(?:trans\((\d+)\)|)(?:\[([\w]+)\]|)(?:\[(\d+\.\d+\.\d+\.\d+)\]|)(?: gtid\((\d+)\)|): (.*)/';
$str = '<15>Jun 08 14:25:09 DP-2 [0x80e0039e][network][debug] xmlfirewall(xml-mgmt): trans(15208451)[request][192.168.7.203] gtid(15208451): url-open: response code 200
<15>Jun 08 14:25:09 DP-2 [0x80e0039f][network][debug] xmlfirewall(xml-mgmt): trans(15208451)[request][192.168.7.203] gtid(15208451): url-open: Finished parsing response from: http://127.0.0.1:63503/
<15>Jun 08 14:25:10 DP-2 [0x80400051][system][debug] trans(143): cpu usage: 2%(10 sec) 3%(1 min) 1%(10 min) 1%(1 hour) 1%(1 day)
<11>Jun 08 14:25:14 DP-2 [0x8080000a][mgmt][error] xmlfirewall(xml-mgmt): trans(15208467)[request][192.168.7.203] gtid(15208467): Requested XML management interface service is disabled.
<11>Jun 08 14:25:14 DP-2 [0x80c00078][multistep][error] xmlfirewall(xml-mgmt): trans(15208467)[request][192.168.7.203] gtid(15208467): Rejected by filter \'ws-enum_56_129\' of rule \'ws-enum_56\'.
<11>Jun 08 14:25:34 DP-2 [Bill_Enquiry][0x80e0015f][mq][error] mq-qm(SAIB03_QMGR): trans(14154309): test connection failed (2059)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);