$re = '/^f[oO]{2}[bB][Aa][rR]/m';
$str = 'foobar - match
FooBar - not match
aWord - not match
fOoBaR - match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);