#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((ht|f)(tp)(s)?(:\/\/))?(([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))(:\d{1,5})?((\/)([\w\.~%-]+))*(\/)?((\?)(([\w]+)(=[\w\.~%-]+)?((&)([\w]+)(=[\w\.~%-]+)?)*)?)?((#)((([\w]+(=[\w\,\*\.~%-]+)?)(&[\w]+(=[\w\,\*\.~%-]+)?)*)|(:~:text=([\w\.~%-]+\,)?([\w\.~%-]+)(\,[\w\.~%-]+){0,2}))?)?)$"
Local $sString = "//Base case" & @CRLF & _
"17hieng.com" & @CRLF & _
"17hieng.com.my" & @CRLF & _
"www.17hieng.com.my" & @CRLF & _
"www.edu.17hieng.com.my" & @CRLF & _
"192.168.1.1" & @CRLF & _
"" & @CRLF & _
"//With protocol" & @CRLF & _
"http://17hieng.com" & @CRLF & _
"https://192.168.1.1" & @CRLF & _
"" & @CRLF & _
"//With Port" & @CRLF & _
"http://17hieng.com:8080" & @CRLF & _
"https://192.168.1.1:443" & @CRLF & _
"" & @CRLF & _
"//With Path" & @CRLF & _
"www.edu.17hieng.com.my/edu" & @CRLF & _
"192.168.1.1/edu/" & @CRLF & _
"http://17hieng.com/edu/edu" & @CRLF & _
"https://192.168.1.1/" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//With query" & @CRLF & _
"www.edu.17hieng.com.my?query=a&b=c" & @CRLF & _
"192.168.1.1/edu/?query=a&b=c@a.com" & @CRLF & _
"http://17hieng.com/edu/edu?query=a" & @CRLF & _
"https://192.168.1.1/?query=a&b&c=1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//With Fragment" & @CRLF & _
"www.edu.17hieng.com.my#about" & @CRLF & _
"192.168.1.1/edu?#line=10,20" & @CRLF & _
"192.168.1.1/edu/?query=a#t=40,8.0&xywh=160,120,320,240" & @CRLF & _
"http://17hieng.com/edu/edu?query=a#:~:text=prefix-,textStart,textEnd,-suffix" & @CRLF & _
"https://192.168.1.1/?query=a&b&c=1#" & @CRLF & _
"" & @CRLF & _
"//domain only" & @CRLF & _
"17hieng.com" & @CRLF & _
"edu.17hieng.com" & @CRLF & _
"17hieng.com/" & @CRLF & _
"edu.17hieng.com/" & @CRLF & _
"" & @CRLF & _
"//domain + https protocol" & @CRLF & _
"https://17hieng.com" & @CRLF & _
"https://edu.17hieng.com" & @CRLF & _
"https://17hieng.com/" & @CRLF & _
"https://edu.17hieng.com/" & @CRLF & _
"" & @CRLF & _
"//domain + http protocol" & @CRLF & _
"http://17hieng.com" & @CRLF & _
"http://edu.17hieng.com" & @CRLF & _
"http://17hieng.com/" & @CRLF & _
"http://edu.17hieng.com/" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//domain + file path" & @CRLF & _
"17hieng.com/cpp" & @CRLF & _
"edu.17hieng.com/cpp" & @CRLF & _
"17hieng.com/cpp/" & @CRLF & _
"edu.17hieng.com/cpp/" & @CRLF & _
"" & @CRLF & _
"//domain + https protocol + file path" & @CRLF & _
"https://17hieng.com/cpp" & @CRLF & _
"https://edu.17hieng.com/cpp" & @CRLF & _
"https://17hieng.com/cpp/" & @CRLF & _
"https://edu.17hieng.com/cpp/" & @CRLF & _
"" & @CRLF & _
"//domain + http protocol + file path" & @CRLF & _
"http://17hieng.com/cpp" & @CRLF & _
"http://edu.17hieng.com/cpp" & @CRLF & _
"http://17hieng.com/cpp/" & @CRLF & _
"http://edu.17hieng.com/cpp/" & @CRLF & _
"" & @CRLF & _
"//domain + multiple folder file path" & @CRLF & _
"17hieng.com/cpp/intro" & @CRLF & _
"edu.17hieng.com/cpp/intro" & @CRLF & _
"17hieng.com/cpp/intro/" & @CRLF & _
"edu.17hieng.com/cpp/intro/" & @CRLF & _
"" & @CRLF & _
"//domain + https protocol + multiple folder file path" & @CRLF & _
"https://17hieng.com/cpp/intro" & @CRLF & _
"https://edu.17hieng.com/cpp/intro" & @CRLF & _
"https://17hieng.com/cpp/intro/" & @CRLF & _
"https://edu.17hieng.com/cpp/intro/" & @CRLF & _
"" & @CRLF & _
"//domain + http protocol + multiple folder file path" & @CRLF & _
"http://17hieng.com/cpp/intro" & @CRLF & _
"http://edu.17hieng.com/cpp/intro" & @CRLF & _
"http://17hieng.com/cpp/intro/" & @CRLF & _
"http://edu.17hieng.com/cpp/intro/" & @CRLF & _
"" & @CRLF & _
"//domain + ?" & @CRLF & _
"17hieng.com?" & @CRLF & _
"edu.17hieng.com?" & @CRLF & _
"17hieng.com/?" & @CRLF & _
"edu.17hieng.com/?" & @CRLF & _
"" & @CRLF & _
"//domain + https protocol + ?" & @CRLF & _
"https://17hieng.com?" & @CRLF & _
"https://edu.17hieng.com?" & @CRLF & _
"https://17hieng.com/?" & @CRLF & _
"https://edu.17hieng.com/?" & @CRLF & _
"" & @CRLF & _
"//domain + http protocol + ?" & @CRLF & _
"http://17hieng.com?" & @CRLF & _
"http://edu.17hieng.com?" & @CRLF & _
"http://17hieng.com/?" & @CRLF & _
"http://edu.17hieng.com/?" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//domain + file path + ?" & @CRLF & _
"17hieng.com/cpp?" & @CRLF & _
"edu.17hieng.com/cpp?" & @CRLF & _
"17hieng.com/cpp/?" & @CRLF & _
"edu.17hieng.com/cpp/?" & @CRLF & _
"" & @CRLF & _
"//domain + https protocol + file path + ?" & @CRLF & _
"https://17hieng.com/cpp?" & @CRLF & _
"https://edu.17hieng.com/cpp?" & @CRLF & _
"https://17hieng.com/cpp/?" & @CRLF & _
"https://edu.17hieng.com/cpp/?" & @CRLF & _
"" & @CRLF & _
"//domain + http protocol + file path + ?" & @CRLF & _
"http://17hieng.com/cpp?" & @CRLF & _
"http://edu.17hieng.com/cpp?" & @CRLF & _
"http://17hieng.com/cpp/?" & @CRLF & _
"http://edu.17hieng.com/cpp/?" & @CRLF & _
"" & @CRLF & _
"//domain + multiple folder file path + ?" & @CRLF & _
"17hieng.com/cpp/intro?" & @CRLF & _
"edu.17hieng.com/cpp/intro?" & @CRLF & _
"17hieng.com/cpp/intro/?" & @CRLF & _
"edu.17hieng.com/cpp/intro/?" & @CRLF & _
"" & @CRLF & _
"//domain + https protocol + multiple folder file path + ?" & @CRLF & _
"https://17hieng.com/cpp/intro?" & @CRLF & _
"https://edu.17hieng.com/cpp/intro?" & @CRLF & _
"https://17hieng.com/cpp/intro/?" & @CRLF & _
"https://edu.17hieng.com/cpp/intro/?" & @CRLF & _
"" & @CRLF & _
"//domain + http protocol + multiple folder file path + ?" & @CRLF & _
"http://17hieng.com/cpp/intro?" & @CRLF & _
"http://edu.17hieng.com/cpp/intro?" & @CRLF & _
"http://17hieng.com/cpp/intro/?" & @CRLF & _
"http://edu.17hieng.com/cpp/intro/?" & @CRLF & _
"" & @CRLF & _
"//domain + parameter" & @CRLF & _
"17hieng.com?name" & @CRLF & _
"edu.17hieng.com?name" & @CRLF & _
"17hieng.com/?name" & @CRLF & _
"edu.17hieng.com/?name" & @CRLF & _
"" & @CRLF & _
"//domain + https protocol + parameter" & @CRLF & _
"https://17hieng.com?name" & @CRLF & _
"https://edu.17hieng.com?name" & @CRLF & _
"https://17hieng.com/?name" & @CRLF & _
"https://edu.17hieng.com/?name" & @CRLF & _
"" & @CRLF & _
"//domain + http protocol + parameter" & @CRLF & _
"http://17hieng.com?name" & @CRLF & _
"http://edu.17hieng.com?name" & @CRLF & _
"http://17hieng.com/?name" & @CRLF & _
"http://edu.17hieng.com/?name" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//domain + file path + parameter" & @CRLF & _
"17hieng.com/cpp?name" & @CRLF & _
"edu.17hieng.com/cpp?name" & @CRLF & _
"17hieng.com/cpp/?name" & @CRLF & _
"edu.17hieng.com/cpp/?name" & @CRLF & _
"" & @CRLF & _
"//domain + https protocol + file path + parameter" & @CRLF & _
"https://17hieng.com/cpp?name" & @CRLF & _
"https://edu.17hieng.com/cpp?name" & @CRLF & _
"https://17hieng.com/cpp/?name" & @CRLF & _
"https://edu.17hieng.com/cpp/?name" & @CRLF & _
"" & @CRLF & _
"//domain + http protocol + file path + parameter" & @CRLF & _
"http://17hieng.com/cpp?name" & @CRLF & _
"http://edu.17hieng.com/cpp?name" & @CRLF & _
"http://17hieng.com/cpp/?name" & @CRLF & _
"http://edu.17hieng.com/cpp/?name" & @CRLF & _
"" & @CRLF & _
"//domain + multiple folder file path + parameter" & @CRLF & _
"17hieng.com/cpp/intro?name" & @CRLF & _
"edu.17hieng.com/cpp/intro?name" & @CRLF & _
"17hieng.com/cpp/intro/?name" & @CRLF & _
"edu.17hieng.com/cpp/intro/?name" & @CRLF & _
"" & @CRLF & _
"//domain + https protocol + multiple folder file path + parameter" & @CRLF & _
"https://17hieng.com/cpp/intro?name" & @CRLF & _
"https://edu.17hieng.com/cpp/intro?name" & @CRLF & _
"https://17hieng.com/cpp/intro/?name" & @CRLF & _
"https://edu.17hieng.com/cpp/intro/?name" & @CRLF & _
"" & @CRLF & _
"//domain + http protocol + multiple folder file path + parameter" & @CRLF & _
"http://17hieng.com/cpp/intro?name" & @CRLF & _
"http://edu.17hieng.com/cpp/intro?name" & @CRLF & _
"http://17hieng.com/cpp/intro/?name" & @CRLF & _
"http://edu.17hieng.com/cpp/intro/?name" & @CRLF & _
"" & @CRLF & _
"//domain + parameter" & @CRLF & _
"17hieng.com?name=CheeHieng" & @CRLF & _
"edu.17hieng.com?name=Chee%20Hieng" & @CRLF & _
"17hieng.com/?name=Chee%20Hieng" & @CRLF & _
"edu.17hieng.com/?name=Chee%20Hieng" & @CRLF & _
"" & @CRLF & _
"//domain + https protocol + parameter" & @CRLF & _
"https://17hieng.com?name=Chee%20Hieng" & @CRLF & _
"https://edu.17hieng.com?name=Chee%20Hieng" & @CRLF & _
"https://17hieng.com/?name=Chee%20Hieng" & @CRLF & _
"https://edu.17hieng.com/?name=Chee%20Hieng" & @CRLF & _
"" & @CRLF & _
"//domain + http protocol + parameter" & @CRLF & _
"http://17hieng.com?name=Chee%20Hieng" & @CRLF & _
"http://edu.17hieng.com?name=Chee%20Hieng" & @CRLF & _
"http://17hieng.com/?name=Chee%20Hieng" & @CRLF & _
"http://edu.17hieng.com/?name=Chee%20Hieng" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//domain + file path + parameter" & @CRLF & _
"17hieng.com/cpp?name=Chee%20Hieng" & @CRLF & _
"edu.17hieng.com/cpp?name=Chee%20Hieng" & @CRLF & _
"17hieng.com/cpp/?name=Chee%20Hieng" & @CRLF & _
"edu.17hieng.com/cpp/?name=Chee%20Hieng" & @CRLF & _
"" & @CRLF & _
"//domain + https protocol + file path + parameter" & @CRLF & _
"https://17hieng.com/cpp?name=Chee%20Hieng" & @CRLF & _
"https://edu.17hieng.com/cpp?name=Chee%20Hieng" & @CRLF & _
"https://17hieng.com/cpp/?name=Chee%20Hieng" & @CRLF & _
"https://edu.17hieng.com/cpp/?name=Chee%20Hieng" & @CRLF & _
"" & @CRLF & _
"//domain + http protocol + file path + parameter" & @CRLF & _
"http://17hieng.com/cpp?name=Chee%20Hieng" & @CRLF & _
"http://edu.17hieng.com/cpp?name=Chee%20Hieng" & @CRLF & _
"http://17hieng.com/cpp/?name=Chee%20Hieng" & @CRLF & _
"http://edu.17hieng.com/cpp/?name=Chee%20Hieng" & @CRLF & _
"" & @CRLF & _
"//domain + multiple folder file path + parameter" & @CRLF & _
"17hieng.com/cpp/intro?name=Chee%20Hieng" & @CRLF & _
"edu.17hieng.com/cpp/intro?name=Chee%20Hieng" & @CRLF & _
"17hieng.com/cpp/intro/?name=Chee%20Hieng" & @CRLF & _
"edu.17hieng.com/cpp/intro/?name=Chee%20Hieng" & @CRLF & _
"" & @CRLF & _
"//domain + https protocol + multiple folder file path + parameter" & @CRLF & _
"https://17hieng.com/cpp/intro?name=Chee%20Hieng" & @CRLF & _
"https://edu.17hieng.com/cpp/intro?name=Chee%20Hieng" & @CRLF & _
"https://17hieng.com/cpp/intro/?name=Chee%20Hieng" & @CRLF & _
"https://edu.17hieng.com/cpp/intro/?name=Chee%20Hieng" & @CRLF & _
"" & @CRLF & _
"//domain + http protocol + multiple folder file path + parameter" & @CRLF & _
"http://17hieng.com/cpp/intro?name=Chee%20Hieng" & @CRLF & _
"http://edu.17hieng.com/cpp/intro?name=Chee%20Hieng" & @CRLF & _
"http://17hieng.com/cpp/intro/?name=Chee%20Hieng" & @CRLF & _
"http://edu.17hieng.com/cpp/intro/?name=Chee%20Hieng" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//domain + mixed-parameter" & @CRLF & _
"17hieng.com?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"edu.17hieng.com?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"17hieng.com/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"edu.17hieng.com/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"" & @CRLF & _
"//domain + https protocol + multi-parameter" & @CRLF & _
"https://17hieng.com?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"https://edu.17hieng.com?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"https://17hieng.com/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"https://edu.17hieng.com/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"" & @CRLF & _
"//domain + http protocol + multi-parameter" & @CRLF & _
"http://17hieng.com?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"http://edu.17hieng.com?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"http://17hieng.com/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"http://edu.17hieng.com/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//domain + file path + multi-parameter" & @CRLF & _
"17hieng.com/cpp?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"edu.17hieng.com/cpp?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"17hieng.com/cpp/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"edu.17hieng.com/cpp/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"" & @CRLF & _
"//domain + https protocol + file path + multi-parameter" & @CRLF & _
"https://17hieng.com/cpp?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"https://edu.17hieng.com/cpp?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"https://17hieng.com/cpp/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"https://edu.17hieng.com/cpp/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"" & @CRLF & _
"//domain + http protocol + file path + multi-parameter" & @CRLF & _
"http://17hieng.com/cpp?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"http://edu.17hieng.com/cpp?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"http://17hieng.com/cpp/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"http://edu.17hieng.com/cpp/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"" & @CRLF & _
"//domain + multiple folder file path + multi-parameter" & @CRLF & _
"17hieng.com/cpp/intro?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"edu.17hieng.com/cpp/intro?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"17hieng.com/cpp/intro/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"edu.17hieng.com/cpp/intro/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"" & @CRLF & _
"//domain + https protocol + multiple folder file path + multi-parameter" & @CRLF & _
"https://17hieng.com/cpp/intro?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"https://edu.17hieng.com/cpp/intro?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"https://17hieng.com/cpp/intro/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"https://edu.17hieng.com/cpp/intro/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"" & @CRLF & _
"//domain + http protocol + multiple folder file path + parameter" & @CRLF & _
"http://17hieng.com/cpp/intro?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"http://edu.17hieng.com/cpp/intro?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"http://17hieng.com/cpp/intro/?name=Chee%20Hieng&age&id=2200282" & @CRLF & _
"http://edu.17hieng.com/cpp/intro/?name=Chee%20Hieng&age&id=2200%20282_" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//Invalid" & @CRLF & _
"htp://17hieng.com" & @CRLF & _
"17Hieng.c" & @CRLF & _
"http:/17hieng.com" & @CRLF & _
"https//17h.my" & @CRLF & _
"code.17Hi@ng.com" & @CRLF & _
"17hieng.com/?=1" & @CRLF & _
"17hineg.com//" & @CRLF & _
"17Hieng.com/hello world" & @CRLF & _
"17Hieng.com<" & @CRLF & _
"17hieng.com/h=1" & @CRLF & _
"17Hieng.com=2" & @CRLF & _
"17hieng.com/?hi=&version" & @CRLF & _
"17hieng.com/?hi=1&version&&" & @CRLF & _
"17hieng.com/?hi=1&version&q%20" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")