$re = '/(hw\/seed\.groovy)/m';
$str = 'somefile.groovy
hw/seed.groovy
otherfile.groovy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);