import re
regex = re.compile(r"(\${1,2})(?:(?!\1)[\s\S])*\1", flags=re.MULTILINE)
test_str = "This is an example $$a \\text{$a$}$$. How to remove it? Another random math expression $\\mathbb{R}$..."
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)