package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`redirect\/([0-9]+)\/?`)
var str = `http://localhost/wordpress/redirect/3/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}