$re = '/([A-Z]{3} *\d{1,2}) *- *(?1)/i';
$str = 'Feb10 -feb 13';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);