package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^v?(?<major>\d+)(\.(?<minor>\d+))(\.(?<patch>\d+))(-(?<build>\d*)(?<compatibility>.*?))?(@(?<digest>.*)|$)`)
var str = `5.2.2@sha256:3483eea0cdfe5a4a67cd1030f8e5f1cce291fcade2a8eb18fbec7f91c54d6bf1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}