$re = '/^v?(?<major>\d+)(\.(?<minor>\d+))(\.(?<patch>\d+))(-(?<build>\d*)(?<compatibility>.*?))?(@(?<digest>.*)|$)/m';
$str = '5.1.2@sha256:3483eea0cdfe5a4a67cd1030f8e5f1cce291fcade2a8eb18fbec7f91c54d6bf1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);