import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d{1,3})\\.\\s\\D*(?:(?!\\b\\d{1,3}\\.\\s)\\d+\\D*)*";
final String string = "In an ACCUPLACER® placement test, there are 20 Sentence Skills questions of two types. The first type consists of sentence-correction questions that require an understanding of sentence structure. These questions ask you to choose the most appropriate word or phrase for the underlined portion of the sentence. The second type consists of construction-shift questions. These questions ask that a sentence be rewritten according to the criteria shown while maintaining essentially the same meaning as the original sentence. Within these two primary categories, the questions are also classified according to the skills being tested. Some questions deal with the logic of the sentence, others with whether or not the answer is a complete sentence, and still others with the relationship between coordination and subordination. Sentence Skills Sample Questions Directions for questions 1 11 Select the best version of the underlined part of the sentence. The first choice is the same as the original sentence. If you think the original sentence is best, choose the first answer. 1. Stamp collecting being a hobby that is sometimes used in the schools to teach economics and social studies. A. being a hobby that is B. is a hobby because it is C. which is a hobby D. is a hobby 2. Knocked sideways, the statue looked as if it would fall. A. Knocked sideways, the statue looked B. The statue was knocked sideways, looked C. The statue looked knocked sideways D. The statue, looking knocked sideways, 3. To walk, biking, and driving are Pat's favorite ways of getting around. A. To walk, biking, and driving B. Walking, biking, and driving C. To walk, biking, and to drive D. To walk, to bike, and also driving \n"
+ "5. Walking by the corner the other day, a child, I noticed, was watching for the light to change. A. a child, I noticed, was watching B. I noticed a child watching C. a child was watching, I noticed, D. there was, I noticed, a child watching 6. Going back to his old school, everything there looked smaller than Don remembered. A. Going back to his old school, B. When he went back to his old school, C. To go back to his old school, D. As he went back to his old school, 7. Painting, drawing and to sculpt are some of the techniques artists such as Picasso used to express themselves. A. Painting, drawing and to sculpt B. To paint, to draw, and sculpting C. Painting, drawing, and sculpting D. To paint, draw, and sculpting 8. Playing sports in school which is an activity meant to teach teamwork and leadership skills students can use later in life. A. which is an activity B. is an activity because it is C. being an activity which is D. is an activity 9. Glancing at his watch, Daniel picked up his speed. A. Glancing at his watch, B. He glanced at his watch, and C. To glance at his watch, D. He glanced at his watch, 10. For a snake, shedding their skin up to eight times a year is part of a natural process. A. For a snake, shedding their skin B. A snake's shedding its skin C. When a snake sheds its skin D. To shed its skin, for snakes © 2016 The College Board. ACCUPLACER SAMPLE QUESTIONS 2 11. I was surprised by the noise peering through the window to see who was at the door. A. I was surprised by the noise peering B. I was surprised by the noise, peered C. The noise surprised me, peering D. Surprised by the noise, I peered Directions for questions 12 22 Rewrite the sentence in your head following the directions given below. Keep in mind that your new sentence should be well written and should have essentially the same meaning as the original sentence. 12. It is easy to carry solid objects without spilling them, but the same cannot be said of liquids. Rewrite, beginning with Unlike liquids, The next words will be A. it is easy to B. we can easily C. solid objects can easily be D. solid objects are easy to be 13. Although the sandpiper is easily frightened by noise and light, it will bravely resist any force that threatens its nest. Rewrite, beginning with The sandpiper is easily frightened by noise and light, The next words will be A. but it will bravely resist B. nevertheless bravely resisting C. and it will bravely resist D. even if bravely resisting 14. If he had enough strength, Todd would move the boulder. Rewrite, beginning with Todd cannot move the boulder The next words will be A. when lacking B. because he C. although there D. without enough 15. The band began to play, and then the real party started. Rewrite, beginning with The real party started The next words will be A. after the band began B. and the band began C. although the band began D. the band beginning 16. Chris heard no unusual noises when he listened in the park. Rewrite, beginning with Listening in the park, The next words will be A. no unusual noises could be heard B. then Chris heard no unusual noises C. and hearing no unusual noises D. Chris heard no unusual noises 17. It is unusual to see owls during the daytime, since they are nocturnal animals. Rewrite, beginning with Being nocturnal animals, The next words will be A. it is unusual to see owls B. owls are not usually seen C. owls during the daytime are D. it is during the daytime that 18. If I want your opinion, I will ask for it. Rewrite, beginning with I won't ask for your opinion The next words will be A. if I want it B. when I want it C. although I want it D. unless I want it 19. It began to rain, and everyone at the picnic ran to the trees to take shelter. Rewrite, beginning with Everyone at the picnic ran to the trees to take shelter The next words will be A. beginning to rain B. when it began to rain C. although it began to rain D. and it began to rain © 2016 The College Board. ACCUPLACER SAMPLE QUESTIONS 3 20. Lucy saw an amazing sight when she witnessed her first sunrise. Rewrite, beginning with Witnessing her first sunrise, The next words will be A. an amazing sight was seen B. when Lucy saw an amazing sight C. Lucy saw an amazing sight D. seeing an amazing sight 21. After three hours of walking the museum, the entire family felt in need of a rest. Rewrite, beginning with The entire family felt in need of a rest The next words will be A. walking through the museum for three hours B. having walked through the museum for three hours C. and they walked through the museum for three hours D. despite having walked through the museum for three hours 22. The big celebration meal was over, and everyone began to feel sleepy. Rewrite, beginning with Everyone began to feel sleepy The next words will be A. and the big celebration meal B. before the big celebration meal C. after the big celebration meal D. although the big celebration meal Reading Comprehension In an ACCUPLACER placement test, there are 20 questions of two primary types in Reading Comprehension. The first type of question consists of a reading passage followed by a question based on the text. Both short and long passages are provided. The reading passages can also be classified according to the kind of information processing required, including explicit statements related to the main idea, explicit statements related to a secondary idea, application, and inference. The second type of question, sentence relationships, presents two sentences followed by a question about the relationship between these two sentences. The question may ask, for example, if the statement in the second sentence supports that in the first, if it contradicts it, or if it repeats the same information. Reading Comprehension Sample Questions Directions for questions 1 9 Read the statement or passage and then choose the best answer to the question. Answer the question based on what is stated or implied in the statement or passage. 1. In the words of Thomas De Quincey, \"It is notorious that the memory strengthens as you lay burdens upon it.\" If, like most people, you have trouble recalling the names of those you have just met, try this: The next time you are introduced, plan to remember the names. Say to yourself, \"I'll listen carefully; I'll repeat each person's name to be sure I've got it, and I will remember.\" You'll discover how effective this technique is and probably recall those names for the rest of your life. The quotation from De Quincey indicates that the memory A. always operates at peak efficiency B. breaks down under great strain C. improves if it is used often D. becomes unreliable if it tires © 2016 The College Board. ACCUPLACER SAMPLE QUESTIONS 4 2. Unemployment was the overriding fact of life when Franklin D. Roosevelt became president of the United States on March 4, 1933. At the time, the government did not systematically collect statistics of joblessness; actually it did not start doing so until 1940. The Bureau of Labor Statistics later estimated that 12,830,000 persons were out of work in 1933, about one-fourth of a civilian labor force of more than 51 million. Roosevelt signed the Federal Emergency Relief Act on May 12, 1933. The president selected Harry L. Hopkins, who headed the New York relief program, to run FERA. A gifted administrator, Hopkins quickly put the program into high gear. He gathered a small staff in Washington and brought the state relief organizations into the FERA system. While the agency tried to provide all the necessities, food came first. City dwellers usually got an allowance for fuel, and rent for one month was provided in case of eviction. This passage is primarily about A. methods of estimating unemployment rates in the 1930s B. the effect of unemployment on United States families C. President Franklin D. Roosevelt's presidency D. the creation of President Roosevelt's FERA program 3. With varying success, many women around the world today struggle for equal rights. Historically, women have achieved greater equality with men during periods of social adversity. The following factors initiated the greatest number of improvements for women: violent revolution, world war, and the rigors of pioneering in an undeveloped land. In all three cases, the essential element that improved the status of women was a shortage of men, which required women to perform many of society's vital tasks. We can conclude from the information in this passage that A. women today are highly successful in winning equal rights B. only pioneer women have been considered equal to men C. historically, women have only achieved equality through force D. historically, the principle of equality alone has not been enough to secure women equal rights 4. All water molecules form six-sided structures as they freeze and become snow crystals. The shape of a snow crystal is determined by temperature, vapor, and wind conditions in the upper atmosphere. A snow crystal is always symmetrical because these conditions affect all six of its sides simultaneously. The purpose of the passage is to present A. a personal observation B. a solution to a problem C. factual information D. opposing scientific theories 5. In the words of Thomas De Quincey, \"It is notorious that the memory strengthens as you lay burdens upon it.\" If, like most people, you have trouble recalling the names of those you have just met, try this: The next time you are introduced, plan to remember the names. Say to yourself, \"I'll listen carefully; I'll repeat each person's name to be sure I have it, and I will remember.\" You'll discover how effective this technique is and probably recall those names for the rest of your life. The passage suggests that people remember names best when they A. meet new people B. are intelligent C. decide to do so D. are interested in people 6. Many people have owned, or have heard of, traditional \"piggy banks,\" coin banks shaped like pigs. A logical theory about how this tradition started might be that because pigs often symbolize greed, the object is to \"fatten\" one's piggy bank with as much money as possible. However, while this idea makes sense, it is not the correct origin of the term. The genesis of the piggy bank is the old English word \"pygg,\" which was a common kind of clay hundreds of years ago in England. People used pots and jars made out of this red \"pygg\" clay for many different purposes in their homes. Sometimes they kept their money in one of the pots, and this was known as a pygg bank.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}