$re = '/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z]).{8,10}$/';
$str = 'qweq123QWE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);