re = /(?<=Day:)\s+\((.+)\)\s+(?=Time:)/m
str = 'Day: ( 8 \\\\ 4 \\\\ 2022) Time: (16:29:41) TesterSlot:9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end