$re = '/\B&\d+\b/m';
$str = '&1234
&123
abc&123
&123abc
&123 &123 &123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);