// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*?(?P<body>{.*})").unwrap();
let string = "{\"channel\":\"crm_process_booking_log\",\"log_type\":\"DEBUG\",\"index_name\":\"crm_process_booking_log\",\"index_type\":\"crm_process_booking_log\",\"error_type\":0,\"message\":{\"data\":{\"STEP\":\"slot_details\",\"slotDetail\":{\"stm_id\":\"684178718\",\"time\":\"14:30:00\",\"end_time\":\"15:30:00\",\"locality_id\":0,\"booking_id\":0,\"freeze_count\":0,\"date\":\"2024-02-07\",\"user_id\":0,\"collection_center_id\":0,\"b2b_zone_id\":0,\"zone_id\":53,\"sample_type_id\":1,\"isavailable\":1,\"isactive\":1,\"set_name\":\"set5\",\"is_peak_hours\":0,\"source\":\"crm\",\"order_group_id\":0,\"old_zone_id\":0,\"samplecollector_id\":0,\"old_set_name\":\"\",\"phlebo_name\":\"\",\"assign_time\":\"0000-00-00 00:00:00\",\"freeze\":0,\"freeze_date\":\"0000-00-00 00:00:00\",\"payment\":0,\"locusStatus\":0,\"lat\":\"\",\"lng\":\"\",\"dropTaskStatus\":0,\"autoAssignStatus\":0,\"pickup_type\":\"home\",\"service_id\":0,\"consultation_id\":0,\"channel_type\":0,\"channel_user\":0,\"vendor_user_id\":\"\",\"created_at\":\"2024-02-05 12:56:10\",\"updated_at\":\"2024-02-05 12:56:10\",\"reference_stm_id\":0,\"phlebo_id\":0},\"amzn_trace_id\":\"Root=1-65c33f1c-29fe535658001b076140677c\"},\"calling_trace\":{\"file\":\"\\/var\\/www\\/newcrm-t25\\/application\\/controllers\\/crmuser\\/crmorder.php\",\"line\":2112,\"function\":\"addProcessBookingLog\",\"class\":\"Enterprise_logger\"}},\"amzn_trace_id\":\"Root=1-65c33f1c-29fe535658001b076140677c\",\"nginx_request_id\":\"c93176430784c9dd4e32e35541e6e31a\",\"timestamp\":\"2024-02-07 13:58:12\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}