import re
regex = re.compile(r"[^#]*?(#\w+)", flags=re.MULTILINE)
test_str = ("This is a #text, which is #full of #hashtags.\n"
"Well, this is not #easy to\n"
"#extract #them. \n"
"I think I #start to lose: #hope.")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)