# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?<katex_all>
(?:
(?<!\\|\$)
(?<katex_open>
\${2}
|
\${1}
)
(?!\$)
\n?
(?<katex_content>.+?)\n?
(?<!\\|\$)
(?<katex_close>\g{katex_open})
(?!\$)
\n?
)
|
(?:
(?<!\\)
(?<katex_open>\\\[)
\n?
(?<katex_content>.+?)\n?
(?<!\\)
(?<katex_close>
\\\]
)\n?
)
|
(?:
(?<!\\)
(?<katex_open>\\\()
\n?
(?<katex_content>.+?)\n?
(?<!\\)
(?<katex_close>
\\\)
)\n?
)
)
"""
test_str = ("$$\n"
"\\Gamma(z) = \\int_0^\\infty t^{z-1}e^{-t}dt\\,.\n"
"$$\n\n"
"This is some text $math \\frac12$\n\n"
"other text $\\unsupported$\n\n"
"Other node \\[ displaymath \\\\[\\\\] \\frac{1}{2} \\] blah\n\n"
"$$ \\int_2^3 $$\n\n"
"more text \\(and math\\) blah\n\n"
"And $math with a\n"
" \\$ sign$.\n\n"
"This should not match↓\n"
"$$$\n"
"\\Gamma(z) = \\int_0^\\infty t^{z-1}e^{-t}dt\\,.\n"
"$$$\n\n"
"This should not match either\n"
"$$\n"
"\\Gamma(z) = \\int_0^\\infty t^{z-1}e^{-t}dt\\,.\n"
"$\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.