#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "access-list.*\b(?<src>\d+\.\d+\.\d+\.\d+).*\-\>.*\b(?<dst>\d+\.\d+\.\d+\.\d+)"
Local $sString = "2011-04026T19:10:17-06:00 ant-fw : %ASA-4-106023: Deny tcp src inside:192.1.1.102/3191 dst outside:204.1.1.28/443 by access-group "inisde" [0x0,0x0]" & @CRLF & _
"2011-04026T19:28:24-06:00 ant-fw : %ASA-4-106100: access-list dmz permitted udp dmz/10.1.1.20(123) -> outside/91.1.1.4(123) hit-cnt 1 first hit [0x7f55f1d2, 0x0]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")