$re = '/(?:SAR - GRP 200.+\s+)*?(?:(?:SARB OUT)|(?<!^))*?(SLNB X1.+\s+)(?=SAR - GRP 300.+\s+)/m';
$str = '+PROG SOFIMSHC
HEAD
PAGE UNII 0
SYST 3D GDIR NEGZ GDIV -1000
CTRL INIT 7
CTRL TOLG 0.010000
CTRL MESH 1
CTRL HMIN -
CTRL NODE 1000
SAR - GRP 200 T 0.300000 MNO 1 MRF 2 DRX 0.000000 0.000000 -1.000000 NX -1.000000 0.000000 0.000000 H1 0.15
SARB OUT
SLNB X1 0.00000000 -6.00000000 2.00000000 X2 0.00000000 -6.00000000 2.10000000
SARB OUT
SLNB X1 0.00000000 -6.00000000 2.10000000 X2 0.00000000 6.00000000 2.10000000
SARB OUT
SLNB X1 0.00000000 6.00000000 2.10000000 X2 0.00000000 6.00000000 2.00000000
SARB OUT
SLNB X1 0.00000000 6.00000000 2.00000000 X2 0.00000000 -6.00000000 2.00000000
SAR - GRP 200 T 0.300000 MNO 1 MRF 2 DRX 0.000000 0.000000 -1.000000 NX -1.000000 0.000000 0.000000 H1 0.15
SARB OUT
SLNB X1 0.00000000 -6.00000000 0.00000000 X2 0.00000000 -6.00000000 2.00000000
SARB OUT
SLNB X1 0.00000000 -6.00000000 2.00000000 X2 0.00000000 6.00000000 2.00000000
SARB OUT
SLNB X1 0.00000000 6.00000000 2.00000000 X2 0.00000000 6.00000000 0.00000000
SARB OUT
SLNB X1 0.00000000 6.00000000 0.00000000 X2 0.00000000 -6.00000000 0.00000000
SAR - GRP 300 T 0.600000 MNO 1 MRF 2 DRX 0.000000 0.000000 -1.000000 NX 0.000000 -1.000000 0.000000 H1 0.15
SARB OUT
SLNB X1 0.00000000 3.00000000 1.80000000 X2 0.00000000 3.00000000 0.00000000
SARB OUT
SLNB X1 0.00000000 3.00000000 0.00000000 X2 -2.45000000 3.00000000 0.00000000
SARB OUT
SLNB X1 -2.45000000 3.00000000 0.00000000 X2 -0.30000000 3.00000000 1.80000000
SARB OUT
SLNB X1 -0.30000000 3.00000000 1.80000000 X2 0.00000000 3.00000000 1.80000000
SAR - GRP 300 T 0.600000 MNO 1 MRF 2 DRX 0.000000 0.000000 -1.000000 NX 0.000000 1.000000 0.000000 H1 0.15
SARB OUT
SLNB X1 0.00000000 -3.00000000 1.80000000 X2 0.00000000 -3.00000000 0.00000000
SARB OUT
SLNB X1 0.00000000 -3.00000000 0.00000000 X2 -2.45000000 -3.00000000 0.00000000
SARB OUT
SLNB X1 -2.45000000 -3.00000000 0.00000000 X2 -0.30000000 -3.00000000 1.80000000
SARB OUT
SLNB X1 -0.30000000 -3.00000000 1.80000000 X2 0.00000000 -3.00000000 1.80000000
SAR - GRP 100 T 0.400000 MNO 1 MRF 2 NX 0.000000 0.000000 1.000000 H1 0.2 CB 15000 CT 15000
SARB OUT
SLNB X1 0.00000000 -6.00000000 0.00000000 X2 0.75000000 -6.00000000 0.00000000
SARB OUT
SLNB X1 0.75000000 -6.00000000 0.00000000 X2 0.75000000 6.00000000 0.00000000
SARB OUT
SLNB X1 0.75000000 6.00000000 0.00000000 X2 0.00000000 6.00000000 0.00000000
SARB OUT
SLNB X1 0.00000000 6.00000000 0.00000000 X2 0.00000000 -6.00000000 0.00000000
SAR - GRP 100 T 0.400000 MNO 1 MRF 2 NX 0.000000 0.000000 1.000000 H1 0.2 CB 15000 CT 15000
SARB OUT
SLNB X1 -2.75000000 -6.00000000 0.00000000 X2 0.00000000 -6.00000000 0.00000000
SARB OUT
SLNB X1 0.00000000 -6.00000000 0.00000000 X2 0.00000000 6.00000000 0.00000000
SARB OUT
SLNB X1 0.00000000 6.00000000 0.00000000 X2 -2.75000000 6.00000000 0.00000000
SARB OUT
SLNB X1 -2.75000000 6.00000000 0.00000000 X2 -2.75000000 -6.00000000 0.00000000
END
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);