#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[abc]{3}|[123]{3}|[()]{2}"
Local $sString = "123" & @CRLF & _
"123" & @CRLF & _
"abc" & @CRLF & _
"a12" & @CRLF & _
"()" & @CRLF & _
")(" & @CRLF & _
"(123)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")