# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\/\*[\s\S]*?\*\/|\/\/.*?$)|(?:\b(?=[A-Za-z][A-Za-z\d]*(?:_[A-Za-z\d]++)+\b)|\G(?<!\b))([A-Za-z\d])([A-Za-z\d]*)(?:_|\b)"
test_str = ("_here _is an_EX4mple, thisisnot_, BUT_th1s_1s, also_not_, y_3_s_sir\n\n"
"/* Ok, we are inside a comment so_this_does_not_count, nor_this\n"
"and_def_not_this\n"
"or_this */ outside_is_fair_game\n\n"
"some other_stuff here /* another_multiline_comment */\n\n"
"no_double__underscore but_yes_this not__this\n"
"this_comes_before // a single_line comment\n\n"
"and stuff_aFTER_tHE_CoMmEnT, except 1cannot_start_with_a_number, and finally_\n"
"not_4cr0ss_mult1p13_l1nes")
subst = "$1\\U$2\\L$3\\E"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.