re = /(--[ \S]*\n)/
str = 'POROSITY-TOTAL POROSITY-TOTAL -- Generated : Petrel
-- Property name in Petrel : PHIT_Edit_July2016
0.1085 0.1136 0.1124 0.1142 0.1141 0.1114 0.1118 0.1158 0.1147 0.1109 0.1216 0.1193 0.1179 0.1204 0.1201 0.1181 0.1200 0.1133
0.1085 0.1038 0.1061 0.1047 0.1006 0.1013 0.1004 0.0976 0.0992 0.1017 0.1034 0.0954 0.0947 0.0964 0.0965 0.0932 0.0902 0.0963
0.0993 0.0919 0.0833 0.0934 0.0916 0.1010 0.1024 0.0971 0.0927 0.0949 0.0956 0.0921 0.0879 0.0954 0.0892 0.0935 0.0895 0.0834
0.0905 0.0924 0.0857 0.0868 0.0823 0.0751 0.0758 0.0765 0.0681 0.0686 0.0714 0.0728 0.0711 0.0760 0.0770 0.0696 0.0672 0.0685
0.0730 0.0684 0.0641 0.0659 0.0714 0.0697 0.0728 0.0725 0.0685 0.0642 0.0600 0.0641 0.0759 0.0665 0.0648 0.0714 0.0742 0.0750
0.0701 0.0725 0.0721 0.0669 0.0639 0.0669 0.0674 0.0686 0.0657 0.0666 0.0558 0.0486 0.0478 0.0452 0.0463 0.0498 0.0444 0.0392
0.0356 0.0424 0.0405 0.0367 0.0274 0.0263 0.0281 0.0252 0.0252 0.0315 0.0322 0.0284 0.0307 0.0255 0.0237 0.0246 0.0258 0.0306
0.0259 0.0230 0.0176 0.0185 0.0205 0.0192 0.0191 0.0204 0.0193 0.0276 0.0220 0.0231 0.0209 0.0293 0.0250 0.0227 0.0286 0.0346'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end