$re = '/(?!AU|TY|DA)[A-Z]{2}/m';
$str = 'AA
AU
foobar
aa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);