import Foundation
let pattern = #"([0]?[1-9]|[1-2][0-9]|[3][0-1])(-|\/|.)(Jan(uary)?|Feb(uary)?|Mar(ch)?|Apr(il)?|May|Jun(e)?|Jul(y)?|Aug(st)?|Sep(tember)?|Oct(ober)?|Nov(ember)?|Dec(ember)?|[0][1-9]|[1][0-2])\2(1?9?[0-9](0?[1-9])|2000)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1-11-1999
1-Nov-1999
1.Nov.1999
1-November-99
35-Nov-2001
31-13-92
32-Feb-1992
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)