use strict;
my $str = '07:00 - 15:30
16:00 bis 20:30
7:00-15:00
7.00 Uhr 16.30 Uhr
7 - 16.30 Uhr
7 - 16 Uhr
7:30 - 16 Uhr
7:15 Uhr bis 16:30 Uhr
7-16.15 Uhr';
my $regex = qr/^(?<start>(?<starthour>[0-9]+)(?:[:\.](?<startminute>[0-9]+))?)(?:[\s]*(?:[-—]|bis|Uhr)[\s]*)*(?<end>(?<endhour>[0-9]+)(?:[:\.](?<endminute>[0-9]+))?)(?:[\s]*(?:Uhr)[\s]*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}