#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?mi)^[A-Za-zÀ-ú](?!(?:.*\.\/\ ){2})(?!(?:.* ){10})(?!.*\.[a-z])[A-Za-zÀ-ú. '-]{5,99}[A-Za-zÀ-ú]$"
Local $sString = "Maria Luiza Barreto" & @CRLF & _
"Maria Luíza barreto da silva" & @CRLF & _
"José João" & @CRLF & _
"José João Paulo" & @CRLF & _
"José João Silva" & @CRLF & _
"Maria Silva" & @CRLF & _
"Maria silva" & @CRLF & _
"maria Silva" & @CRLF & _
"MariaSilva" & @CRLF & _
" Maria Silva" & @CRLF & _
"Maria Silva " & @CRLF & _
"Maria da Silva" & @CRLF & _
"Marina Silva" & @CRLF & _
"Maria / Silva" & @CRLF & _
"Maria Silva" & @CRLF & _
"Maria Silva" & @CRLF & _
"Maria G. Silva" & @CRLF & _
"Maria McDuffy" & @CRLF & _
"Getúlio Dornelles Vargas" & @CRLF & _
"Maria das Flores" & @CRLF & _
"John Smith" & @CRLF & _
"John D'Largy" & @CRLF & _
"John Doe-Smith" & @CRLF & _
"John Doe Smith" & @CRLF & _
"Hector Sausage-Hausen" & @CRLF & _
"Mathias d'Arras" & @CRLF & _
"Martin Luther King Jr." & @CRLF & _
"Ai Wong" & @CRLF & _
"Chao Chang" & @CRLF & _
"Alzbeta Bara" & @CRLF & _
"Marcos Assunção" & @CRLF & _
"Maria da Silva e Silva" & @CRLF & _
"Juscelino Kubitschek De Oliveira" & @CRLF & _
"Natalia maria" & @CRLF & _
"Natalia aria" & @CRLF & _
"Natalia orea" & @CRLF & _
"Maria dornelas" & @CRLF & _
"María Luiza" & @CRLF & _
"Samuel eto'" & @CRLF & _
"Maria da Costa e Silva" & @CRLF & _
"Samuel Eto'o" & @CRLF & _
"Maria Luiza Barreto Da Silva" & @CRLF & _
"Nathali Grasiela Quintans Andrade da Silva Barreto" & @CRLF & _
"Nathali G. Q. A. Da S. Barreto" & @CRLF & _
"María " & @CRLF & _
" M " & @CRLF & _
"Petros barreto da silva " & @CRLF & _
"M D " & @CRLF & _
"(?<! )[A-Za-zÀ-ú']{2,}\\s[A-Za-zÀ-ú' ]{2,}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")