# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r" +"
test_str = ("The European l a n g u a g es ar e members of the same fa m i l y \n"
". Their sep a rate e xi ste nce is a myth . F or s c i e n c e , music, \n"
"sport , etc, Europe uses the s a m e v oca bula ry. The languages o n l y d \n"
"i f f e r i n t heir grammar, their pro nu n c iation and their most common \n"
"words. Everyone realizes why a new common language would be desirable: one could \n"
"refuse to pay expensive translators.")
subst = "(@)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.