$re = '/(?:\G(?!^)|(?=(?:[e-g]\d+)+c))[e-g]\d+/';
$str = 'e123f654g933c
-> e123 f654 g933
or
e123f654g933ce99f77g66c
-> e123 f654 g933 e99 f77 g66';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);