import re
regex = re.compile(r"^([\d\- :]+)\[([a-z-0-9]+)\] *\w+ *\[\w+\]\[([a-z0-9]+)\] - \w+:([\d\- :.]+)-\w+:([\d\- :.]+)-(.*)", flags=re.MULTILINE)
test_str = "2018-12-03 00:00:00:652 [http-nio-8080-exec-4] INFO [siftLog][fedb9917cd6e4833a69182044395a53c] - logTime:2018-12-02 23:59:59.326-receiveTime:2018-12-03 00:00:00.000-{\"biz\":{\"openCard\":\"0\",\"boxSn\":\"019952634704\"},\"performance\":{\"staticComplieTime\": 0,\"nodejsRequestTime\":81,\"computeDOMCustTime\":277,\"computeHTMLDownload\":53,\"wechatRedirectTime\":861,\"computeTCP\":0,\"renderTime\":466,\"wechatRedirect\":1,\"AuthRedirectTime\":861,\"allRenderTime\":1408,\"computeDOMComplie\":270,\"browserInitTime\":42,\"computeD NS\":0,\"staticDownloadTime\":7,\"whitePageTime\":1401,\"computeHTMLResponseTime\":210},\"id\":\"1543766399062-3342727d-aa75-4a06-9cc9-5851b5c0e811\",\"event\":\"performance\",\"sys\":{\"userAgent\":\"Mozilla/5.0 (Linux; Android 8.0.0; SM-A530F Build/R16NW; wv) AppleWe bKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/70.0.3538.80 Mobile Safari/537.36 MicroMessenger/6.7.3.1341(0x26070340) NetType/4G Language/ru Process/tools\"}}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")