import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^-/]*(?=[^/]*/$)";
final String string = "https://example.com/notwantedstring/anotherunwantedstring/i-want-this-string/\n"
+ "https://www.example.com/abdfsg63/sfdgfv/dfgffk/sf-adfgdg-fgfg-1/\n"
+ "https://www.example.com/abdfsg63/sfdgfv/dfgffk//";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}