$re = '/(?:\/us)?\/[a-z]{2}[_-][a-z]{2}(?:\/?$|(?=\/))|\/[a-z]{2}(?:\/?$|(?=\/))^([a-z]{2}\/retail)/m';
$str = '/us/en_us/retail/en
/us/en_us/retail
/gb/en_gb/retail/en-uk/
/us/en_us/e/retail/Ctral/Apps/jcr:content/par/expandableciner_57473905/image/file.img.png/1496964235.png
/gb/retail/cowabunga
/gb/en_gb/retail/en-uk
/gb/en_gb/retail/en-uk/blah';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;