$re = '/(?<=USD)\d+/m';
$str = 'USD 100
USD100
USD50
EUR50
USD500
MXN500';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);