$re = '/(?<!\w)\.?(lh)\.?(?!\w)/m';
$str = 'lh l.h. lh. -lh- l.h .lh plh phli lhp 1lh lh1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);