$re = '/(?<=\[)[^\[]*?(?=\])/m';
$str = '"Let f(a) in the[[f(a)=a+1] variable a be 1[f(a)=a+1]]00 in the expression [[f(a)=a+1]]."
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);